Humax iCord HD+ use in the UK?

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Humax iCord HD+ use in the UK?

      Hi

      I have been given an iCord HD+ box intended for the German market but am trying to use it in the UK to receive Freesat channels (I'm aware of the limitation regarding the Freesat 7 day EPG not being available on a non-Freesat branded box) via a former Sky+ dish (i.e. it has two cables coming out the wall - more below..).

      I'm a newbie when it comes to the technical details of satellite tv so apologies for any stupid questions but so far I've run into a few issues that I hope someone on here may be able to help resolve:

      1. Even after doing a factory reset of the box I am not able to change the timezone it thinks its in - its not an option in the installation wizard on the version of firmware this box has installed. Therefore the clock, and now/next times are all 1 hour ahead of my local time. Is anyone able to suggest a way to fix this?

      2. Although as I say I believe the dish is an ex-Sky+ installation (by previous householders) and I have 2 co-ax cables coming in through the wall from the dish to connect to the Humax twin tuners - I only seem to get reception on one. As I said, I'm a bit of newbie so can someone suggest steps I should follow to diagnose what the issue is?

      3. The channel list (all 300+ it can detect) is in a somewhat random order and includes both free to air and encrypted stuff - although editing it does appear to be possible it would take a while - is there a short cut for example could I import a channel list (main Freesat channels will do for me for now) from somewhere via USB?

      4. For the BBC/ITV HD channels the default "english dolby" audio channel gives me no sound - only get sound if I select the "audio description" channel, which I don't fully understand? The TV is connected via a HDMI cable and I've no other amp or anything else - is the DD audio only sent to the SPDIF output?

      I believe I'm running the latest firmware as the box says there are no updates when I tried to update it on-line.

      Thanks for any advice anyone can give.