Configure ip address in iCord for FTP and web GUI connections

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Configure ip address in iCord for FTP and web GUI connections

      Please can someone tell me how to configure the ip address in the iCord for connection to a wifi network?

      I imagine I need to do the following as the configure automatically vua DHCP doesn't seem to work:

      1. Connect the iCord via an ethernet cable to the wifi router (in this case an Apple Mac Airport Express). Should this be a patch cable as using the cables I have there seems to be no connection?

      2. In the iCord enter the ip address, subnet mask, router address and DNS address for the airport extreme network? (or the ip address of the Airport express module rather than the main Airport Extreme router?)

      3. Connect via Cyberduck for FTP connection?

      4. Connect via Firefox browser using the ip address for web GUI interface?

      If connecting using an Apple Mac is a problem, I could also use Parallels to connect using Windows XP.

      Any advice on this process would be appreciated.
    • GUI connection works only if you have installed MiniRoot.

      A patch cable is not needed and DHCP usually works - you can see if the iCord is connected to Network in the menu too.

      So - maybe you describe what happens (or not) more in detail...

      Nie mehr ohne meine Pronto...
    • Hi Duddits, thanks for responding to my question.

      1. I have an iCord HD
      2. I have installed Miniroot 1.00 plus the Miniroot 1.01 update

      Is there any way to check that these have installed successfully?

      I have tried connecting a Belkin High Speed Modem Cable to the Airport Express router. This works to connect between my Macbook Pro and the router.

      The router has settings as follows:
      Airport ID: 00:17:F2:E1:C2:65
      Ethernet ID: 00:17:F2:E1:C2:64
      Wireless Mode: Participate in a WDS network
      Wireless Security: WPA/WPA2 Personal
      Channel 8
      Wireless Clients: –
      Connet Using: Airport (WDS)
      IP Address:

      Connection Sharing: Distribute a range of IP addresses
      IP Address:
      Subnet Mask:
      Router address:
      DNS Servers: -
      Domain Name (my internet provider)
      DHCP Client ID:

      DHCP Beginning Address:
      DHCP Ending Address:

      On the iCord HD I have gone into the Menu to the Network settings and FTP Server and have clicked "enable' (so "disable" is now visible).
      In Ethernet Configuration when I click on Configure IP - DHCP and click the "Apply" button, I get the message "Fail to connecting"

      If I go to Configure IP address Manually and enter IP address, subnet mask etc. of the router and click the "Apply" button, I also get the message "Fail to Connecting"

      This is why I was thinking that perhaps I need to use a patch cable rather than a CAT 5 or modem cable?

      Thanks in advance for any suggestions.
    • No - this seems to be okay and should work (but you should disable FTP if you want to use the vsftp, which is integrated in MiniRoot). I think the IP you noted for your router is your "external" IP? So your Mac has an IP 192.168.100.XXX ?

      Did you check your cable for damages? A CAT5 is fine

      Please take a look at your MAC in iCord menu - it is not like FF:FF:FF:FF:FF ?

      Nie mehr ohne meine Pronto...
    • Hi again Duddits, my MAC address is now restored thanks to ochzoetna. I didn't realise there was vsftp and FTP. So I will try disabling FTP then. The modem cable I am using works ok to communicate between the router and MacBook, so should be ok.

      What IP should I enter in the iCord? The relay router that the iCord is connected to, my MacBook Pro or the main wifi router network IP?

      The router/network has an IP address as you say

      My MacBook Pro has passive FTP enabled.


    • When disable FTP Server, then "Ethernet Configuration" shows IP Address in other words, the IP address details I entered manually are not visible. When FTP Server is enabled, the IP address is visible under Ethernet Connection but it still shows "Network Disconnected". So far Configure IP with DHCP will not work.
    • The problem was the ethernet cable! Obviously the iCord will only connect with certain cables. I used a CAT 5 cable from my network and this works!

      So now to experiment with MiniRoot and the web GUI. Any tips from English speaking members who are using this are welcome.
    • I'm running into the same problem, both when attempting manual network configuration or DHCP.
      The iCord HD keeps saying "not connecting" when pressing the "Apply" button.
      And one level up, in the network overview, it says "network disconnected" and some old IP address.

      The "network disconnected" clearly isn't true: the router lists the iCord HD in the attached devices (with the incorrect IP address; this address can ONLY come from the iCord HD itself, so it does talk to the router).
      After seeing your tip I tried three different network cables (CAT6, CAT5e and an old, long CAT5 cable that I used successfully on the iCord HD in the past.
      Nope! It stubbornly refuses to update the network configuration.
      Of course I did multiple restart of both the iCord HD and the router; all to no avail.

      Anyone any suggestions?
      I getting a bit desperate....

      (Answer in English, German, or Dutch are appreciated; I'll provide an English summary if I'm able to make any progress.)