Angepinnt Platoon 1.2.2

      Wenn du Filme auf deinem PC anschauen willst, welche sich auf der Festplatte des Icord HD+ befinden (nicht HD+ Aufnahmen), dann kannst du die Freeware XBMC (schau dich auch hier im Forum um) nutzen. Mit der klappt das! Da du dich hier jedoch im Icord HD Bereich befindest, solltest du Anfragen dieser Art eher im entsprechenden Bereich posten!

      Grüße

      obsidianer

      Keine FTP-Verbindung zwischen Platoon und ICord möglich (Win7 64 Bit)

      Hallo,

      ich kann keine FTP-Verbindung zwischen Platoon und ICord herstellen. Ich habe schon das Forum durchsucht, aber nichts hat geholfen.

      Der Humax ist direkt über Netzwerkkabel mit dem PC verbunden (also per LAN). Mit TotalCommander und Filezilla klappt die Verbindung einwandfrei, ich kann Dateien von und zum Icord kopieren.
      Aber Platoon mag nicht, weder 1.2.1 noch 1.2.2.

      Beim Versuch, eine Datei hochzuladen erscheint folgendes Protokoll,
      Heikes 40. Geburtstag: starte ftpTransfer:
      01.29.2012 19:23:36.6356 Connect 192.168.10.200
      01.29.2012 19:23:36.6406 220 Welcome to i-CORD HD FTP Connection.
      01.29.2012 19:23:36.6426 USER HumaxFTP
      01.29.2012 19:23:36.6926 331 Password required for humaxftp.
      01.29.2012 19:23:36.6926 PASS ****
      01.29.2012 19:23:36.7426 230 User logged in, proceed.
      01.29.2012 19:23:36.7436 CWD /media
      01.29.2012 19:23:36.7936 250 File action is successful. Proceed.
      01.29.2012 19:23:36.8056 CWD /media/Video
      01.29.2012 19:23:36.8556 250 File action is successful. Proceed.
      01.29.2012 19:23:36.8566 PWD
      01.29.2012 19:23:36.9066 257 "/mnt/hd3/Video" is current working dir.
      01.29.2012 19:23:36.9186 PASV
      01.29.2012 19:23:36.9686 502 Command not implemented.
      01.29.2012 19:23:36.9716 PORT 192,168,10,201,203,248
      01.29.2012 19:23:37.0216 200 Port command successful
      01.29.2012 19:23:37.0216 LIST
      Heikes 40. Geburtstag: ftpTransfer abgebrochen


      und es erscheint das angehängte Bild PlatoonFTP2.jpg.


      Beim Versuch einen Icord Ordner zu wählen, erscheint das angehängte Bild PlatoonFTP.jpg,

      anschliessend stürzt das Programm ab, bzw. wird zwangsweise geschlossen.


      Mein System ist Win7 (64-Bit), mit Kaspersky Internet Security 2011 als Schutzpaket. Platoon ist sowohl in der Windows-Firewall als auch in der Kaspersky Firewall als vertrauenswürdig angegeben (gleiche Einstellung wie für TotalCommander und Filezilla).

      Hat noch jemand eine Idee woran das liegen könnte?

      Vielen Dank im Voraus für die Hilfe.

      Gruß
      Bernd
      iCord HD 500 GB (Dez.2008), neue ELKOs seit Nov. 2012, FW 1.00.38, MiniRootFS
      Hallo Shrike,

      der timeout-Wert steht auf 10000. Auch mit 20000 und deaktivierten Firewalls (Windows und Kaspersky) keine Änderung. Verbindung wird aufgebaut, aber es kommt nicht zur Übertragung.

      Anfangs hatte ich mit TotalCommander und Filezilla das gleiche Verhalten, aber nach Abschalten der Firewalls bzw. dann nach Eintragen der Programme in die Liste der zugelassenen Programme gings dann. Nur bei Platoon hat das nicht geklappt.
      Platoon hat in beiden Firewalls exakt die gleichen Einstellungen wie TotalCommander und Filezilla.

      Gruß
      Bernd

      PS. Bin nicht jeden Tag online, deshalb kommt die Antwort manchmal etwas verzögert...
      iCord HD 500 GB (Dez.2008), neue ELKOs seit Nov. 2012, FW 1.00.38, MiniRootFS
      Der ftp server von humax kann kein passives FTP und es sieht danach aus, als wuerde das verwendet:

      Quellcode

      1. 01.29.2012 19:23:36.9186 PASV
      2. 01.29.2012 19:23:36.9686 502 Command not implemented.


      vielleicht kann man platoon konfigurieren, dass kein passiver modus verwendet wird?
      Falls das "PASV"-Kommando fehlschlägt, greift Platoon automatisch auf den 'active mode' zurück.

      Quellcode

      1. SendFTPCommand("PASV")
      2. ReadReply()
      3. ' Falls der Server nicht den passiven Modus kennt, auf aktiven Modus zurückgreifen
      4. If intReply <> 227 Then
      5. my_bolPassive = False
      6. OpenDataSocket()
      7. Exit Sub
      8. End If


      Gruß,
      Shrike
      iCord HD 2000GB (CORTEX 1.00.39) =HDMI=> Yamaha RX-V2700 AV-Receiver =HDMI=> Pioneer PDP-507XA Plasma-TV
      Hallo
      Korrektur: PASV funktioniert auch bei Filezilla nicht. Hier ein LOG:
      Status: Verbinde mit 192.168.10.200:21...
      Status: Verbindung hergestellt, warte auf Willkommensnachricht...
      Antwort: 220 Welcome to i-CORD HD FTP Connection.
      Befehl: USER HumaxFTP
      Antwort: 331 Password required for humaxftp.
      Befehl: PASS ****
      Antwort: 230 User logged in, proceed.
      Befehl: SYST
      Antwort: 215 UNIX system type.
      Befehl: FEAT
      Antwort: 500 Syntax error, command unrecognized.
      Status: Verbunden
      Status: Empfange Verzeichnisinhalt...
      Befehl: PWD
      Antwort: 257 "/media" is current working dir.
      Befehl: TYPE I
      Antwort: 200 Port command successful
      Befehl: PASV
      Antwort: 502 Command not implemented.

      Befehl: PORT 192,168,10,201,193,129
      Antwort: 200 Port command successful
      Befehl: LIST
      Antwort: 150 Opening data connection for directory list
      Antwort: 226 Closing data connection.
      Status: Anzeigen des Verzeichnisinhalts abgeschlossen
      Status: Empfange Verzeichnisinhalt...
      Befehl: CWD /media/Video
      Antwort: 250 File action is successful. Proceed.
      Befehl: PWD
      Antwort: 257 "/mnt/hd3/Video" is current working dir.
      Befehl: PASV
      Antwort: 502 Command not implemented.

      Befehl: PORT 192,168,10,201,193,130
      Antwort: 200 Port command successful
      Befehl: LIST
      Antwort: 150 Opening data connection for directory list
      Antwort: 226 Closing data connection.
      Status: Anzeigen des Verzeichnisinhalts abgeschlossen
      Status: Empfange Verzeichnisinhalt...
      Befehl: CWD /media/Music
      Antwort: 250 File action is successful. Proceed.
      Befehl: PWD
      Antwort: 257 "/mnt/hd4/Music" is current working dir.
      Befehl: PASV
      Antwort: 502 Command not implemented.
      Befehl: PORT 192,168,10,201,193,131
      Antwort: 200 Port command successful
      Befehl: LIST
      Antwort: 150 Opening data connection for directory list
      Antwort: 226 Closing data connection.
      Status: Anzeigen des Verzeichnisinhalts abgeschlossen
      Status: Empfange Verzeichnisinhalt...
      Befehl: CWD /media
      Antwort: 250 File action is successful. Proceed.
      Befehl: PWD
      Antwort: 257 "/media" is current working dir.
      Befehl: CWD Video
      Antwort: 250 File action is successful. Proceed.
      Befehl: PWD
      Antwort: 257 "/mnt/hd3/Video" is current working dir.
      Status: Anzeigen des Verzeichnisinhalts abgeschlossen

      Gruß
      Bernd

      iCord HD 500 GB (Dez.2008), neue ELKOs seit Nov. 2012, FW 1.00.38, MiniRootFS
      Das hat schon seine Richtigkeit. Das 'PASV'-Kommando ist im Humax ftp-server nicht integriert. Das ist nicht das Problem, sonder daß der iCord auf das 'LIST'-Kommando von Platoon nicht mehr antwortet.

      Wenn ich bei mir in Platoon den Protokolverlauf ansehe, dann entspricht es im Kern dem, was du auch in Filezilla siehst. Deshalb steh' ich im Augenblick etwas auf dem Schlauch ... aber keine Angst, ich laß da nicht locker. Ich brauch' nur etwas Zeit zum Nachdenken. :Kaffee:

      Gruß,
      Shrike
      iCord HD 2000GB (CORTEX 1.00.39) =HDMI=> Yamaha RX-V2700 AV-Receiver =HDMI=> Pioneer PDP-507XA Plasma-TV
      Versuch mal bitte in Platoon in den ftp-Einstellungen den port-Bereich auf 49537-49553 zu beschränken (das ist der Bereich, mit dem bei dir Filezilla erfolgreich kommuniziert).

      edit: dabei auch wieder die firewall temporär ausschalten

      Gruß,
      Shrike
      iCord HD 2000GB (CORTEX 1.00.39) =HDMI=> Yamaha RX-V2700 AV-Receiver =HDMI=> Pioneer PDP-507XA Plasma-TV
      Ich bin jetzt den ganzen Ablauf nochmal durchgegangen. Und da gibt es für mich nur die Erklärung, daß die vom iCord eingehende Datenverbindung an deinem Rechner blockiert wird. Sowas macht eigentlich nur eine firewall. Wenn du also testweise deine beiden firewalls ausschaltest, stelle dabei auch sicher, daß sie tatsächlich nicht mehr aktiv sind. Oder du hast noch eine vergessene dritte firewall im System am laufen.

      Um meine Schlußfolgerung zu untermauern, hab' meine Windows firewall mal aktiviert und die Regel für eingehenden Verbindung für Platoon deaktiviert. Das Ergebnis war die gleiche Fehlermeldung an der exakt gleichen Protokolstelle wie bei dir.

      Gruß,
      Shrike
      iCord HD 2000GB (CORTEX 1.00.39) =HDMI=> Yamaha RX-V2700 AV-Receiver =HDMI=> Pioneer PDP-507XA Plasma-TV
      Hallo Shrike,

      Hier ist der Inhalt von C:\Windows\Microsoft.NET\Framework:





      Die Einschränkung der Ports hat auch nichts gebracht.

      ich hab ja auch den Verdacht, dass es irgendwie mit den Firewalls zusammenhängt. Aber ich weiß momentan noch nicht wo ich noch danach suchen soll.
      Als ich den Icord zum ersten mal ans LAN angeschlossen hatte hat die Windows-Netzwerkfreigabe den LAN-Anschluß als "Offentliches Netzwerk" eingestellt.
      Bei TotalCommander und Filezilla hat es auch dann erst geklappt, nachdem ich sie in der Windows-Firewall freigegeben hatte. In der Kaspersky-Firewall musste ich nichts ändern.
      Nur eben bei Platoon hat es nicht funktioniert.
      Ich habe die Windows-Firewall und die Kaspersky Firewall (Kaspersky Internet Security 2011 war auf dem neuen Rechner drauf), ansonsten wüßte ich nicht was da sonst noch sein könnte.
      Nun ja, die Kaspersky Internet Security 2011 läuft eh nur noch 2 Monate, d.h. ich muß sie demnächst durch was anderes ersetzen. In dem Zuge werde ich dann nach der De-Installation es nochmal probieren.

      Bis dahin erstmal vielen Dank für Deine Mühe! Das Forum hat mir schon öfters viele nützliche Informationen geliefert. Dafür auch nochmal herzlichen Dank für das Engagement.

      Viele Grüße
      Bernd
      iCord HD 500 GB (Dez.2008), neue ELKOs seit Nov. 2012, FW 1.00.38, MiniRootFS
      Hallo allerseits,

      kurzes Update: Auch nach der Komplett-Deinstallation der Kaspersky Internet Security 2011 unverändertes Bild: kein Zugriff über Platoon auf den Icord.
      Also ist die Kaspersky Internet Security 2011 nicht schuld am Problem...
      Es muß also was anderes sein-

      Gruß
      Bernd
      iCord HD 500 GB (Dez.2008), neue ELKOs seit Nov. 2012, FW 1.00.38, MiniRootFS